Error trying to get it run

Mar 5, 2014 at 12:24 PM
Edited Mar 5, 2014 at 12:40 PM
Hi,

installed version 2.1.3 on Sharepoint 2010. Tried nearly any combination found here for the domains-configuration, but regardless of the entry, the following error message appears:

System.NullReferenceException: Object reference not set to an instance of an object. at ADUserEditorWebpart.ADUserEditorWebpart.ADUserEditorWebpart.selectUser()

domain is named companylan.lan.local, tried with:
<domains><domain name="companylan" path="LDAP://dc001.companylan.lan.local/DC=companylan,DC=lan,DC=local" usr="companylan\admin" pwd="pass123" /></domains>

Any idea, why this happens?

best regards
Marty
Coordinator
Mar 9, 2014 at 11:17 AM
Hi Marty,

Are you trying to use the web part in "self-service" mode?
Do you have multiple AD forests?
Mar 10, 2014 at 8:13 AM
Hi,

thanks for answering.
Yes, i tried the self-service mode. But the user-picker mode is also not working.

The following error message appears in user-picker-mode:
System.Xml.XmlException: 'Zertifizierungen' is an unexpected token. The expected token is '"' or '''. Line 1, position 1387. at System.Xml.XmlTextReaderImpl.Throw(Exception e) at System.Xml.XmlTextReaderImpl.ParseAttributes() at System.Xml.XmlTextReaderImpl.ParseElement() at System.Xml.XmlTextReaderImpl.ParseElementContent() at ADUserEditorWebpart.ADUserEditorWebpart.Utilities.getUserPropertiesFromXML(String XML) at ADUserEditorWebpart.ADUserEditorWebpart.ADUserEditorWebpart.CreateChildControls()

We are running one AD-forest with a root domain "lan.local", i work in the subdomain companylan.lan.local.
Coordinator
Mar 11, 2014 at 11:52 PM
it looks like there's a problem in the xml config for the fields. could you post it here so I can have a look?
Mar 14, 2014 at 2:02 PM
Edited Mar 14, 2014 at 2:06 PM
i did not change the field, it is the default entry after the installation:

<properties>
 <property adname='displayName' name='Vollständiger Name' type='readonly' />
 <property adname='thumbnailPhoto' name='Foto' type='image' />
 <property adname='sn' name='Nachname' type='textbox' />
 <property adname='givenName' name='Vorname' type='textbox' />
 <property adname='manager' name='Abteilungsleiter' type='person' />
 <property adname='assistant' name='Assistent(in)' type='person' />
 <property adname='department' name='Abteilung' type='listbox' values="IT;Human Resources;Bio;Security" /> 
 <property adname='title' name='Berufsbezeichnung' type='textbox' />
 <property adname='employeeType' name="Art der Anstellung" type='dropdown' values='Techniker,tech;Abteilungsleiter,mgr;Direktor,dir' />
 <property adname='telephoneNumber' name='Telefonummer' type='textbox' />
 <property adname='otherTelephone' name="Weitere Telefonnummer" type='multitextbox' values="4" />
 <property adname='mobile' name='Handynummer' type='textbox' />
 <property adname='facsimileTelephoneNumber' name='Faxnummer' type='textbox' />
 <property adname='l' name='Stadt' type='dropdown' values='New-York;Washington' />
 <property adname='physicalDeliveryOfficeName' name='Büro' type='textbox' />
 <property adname='company' name='Unternehmen' type='textbox' />
 <property adname='accountExpires' name='Vertragsende' type='date' />
 <property adname='extensionCustomAttribute1' name=Zertifizierungen" type='checkboxlist' values='Cisco,CIS;Microsoft,MIC;Oracle,ORA' />
</properties>
Sorry, the editor here does not save the linefeeds.
Mar 14, 2014 at 2:08 PM
To test, i changed it to:
<properties><property adname='displayName' name='Vollständiger Name' type='readonly' /></properties>
Result: the same.
Coordinator
Mar 14, 2014 at 3:34 PM
Edited Mar 14, 2014 at 3:51 PM
There is a quote missing from the default xml :S

You have to change from

name=Zertifizierungen"
to
name="Zertifizierungen"

to avoid the "XmlException" error.
Mar 21, 2014 at 7:58 AM
Thank you very much, it is working now.
Coordinator
Mar 27, 2014 at 9:30 PM
It's been fixed in the last version 2.1.4: https://nominesptools.codeplex.com/releases/view/107079